Sysadmin Garden of Eden Docs

Version 1337.42.0

Cheat Sheet

Quick Run Snippets

Automatic OS and Firmware Update

1
2
3
4
5
6
7
8
/system routerboard settings set auto-upgrade=yes
/system package update
check-for-updates once
:delay 3s;
:if ( [get status] = "New version is available") do={ install }
:delay 1s:
/system routerboard upgrade
/system reboot

Config

Set Hostname / Identity

1
2
/system identity
set name=HOSTNAME

Set Timezone

To Europe/Berlin.

1
2
/system clock
set time-zone-name=Europe/Berlin

Disable Ports beginning with ether

1
:foreach i in=[/interface find name~"ether"] do={ /interface ethernet set $i disabled=yes }
1
:foreach i in=[/interface find name~"sfp-sfpplus"] do={ /interface ethernet set $i advertise=10000M-full; }

Enable Graphs / Graphing

1
2
3
4
5
6
7
/tool graphing
set page-refresh=240
/tool graphing interface
add
/tool graphing resource
# Put your admin / configuration network here
add allow-address=172.16.0.0/24

Set Boot target of Device

1
2
/system routerboard settings
set boot-os=router-os
Last updated on 31 Jan 2020
Published on 25 Jan 2020
Edit on GitHub